[CF-metadata] new standard names for flood simulation

Eizi TOYODA toyoda at npd.kishou.go.jp
Fri Sep 18 04:43:04 MDT 2015


Dear Alison,

Thanks for ticketing my proposals.   Your refinements of the language are
mostly welcome, but I realized I need to clarify one point (thanks to your
assistance) in items 8 and 9.

The hydrology people are interested in when a given region is safe to
enter.  So the question is the time the flood water goes below the
threshold for the *last* time, not for the *first* time.

So I'd like to have the first sentences of 8 and 9 like as follows.  I
always welcome more natural English language.

Best Regards,
Eizi


8. time_when_flood_water_falls_below_threshold

The quantity with standard name time_when_flood_water_falls_below_threshold
is the time elapsed between the breaking of a levee (origin of flood water
simulation) and the instant when the depth *first* falls below a given
threshold, having already risen to its maximum depth, at a given point in
space.

'The quantity with standard name
time_when_flood_water_falls_below_threshold is the time elapsed between the
breaking of a levee (origin of flood water simulation) and the instant when
the depth falls below a given threshold *for the last time*, having already
risen to its maximum depth, at a given point in space.

9. flood_water_duration_above_threshold

'The quantity with standard name flood_water_duration_above_threshold is
the time elapsed between the instant when the flood depth first rises above
a given threshold until the time it falls below the same threshold for a
given point in space.

'The quantity with standard name flood_water_duration_above_threshold is
the time elapsed between the instant when the flood depth first rises above
a given threshold until the time it falls below the same threshold *for the
last time* for a given point in space.




Best Regards,
--
Eiji (aka Eizi) TOYODA
http://www.google.com/profiles/toyoda.eizi

On Thu, Sep 17, 2015 at 1:26 AM, <alison.pamment at stfc.ac.uk> wrote:

> Dear Eizi,
>
> My apologies for not joining the original discussion of these names – I
> was on annual leave at the time. I’ve added entries for all your proposals
> to the list of names under discussion:
> http://cfeditor.ceda.ac.uk/proposals/1?status=active&namefilter=&proposerfilter=Eizi&descfilter=&unitfilter=&yearfilter=&commentfilter=&filter+and+display=Filter
> .
>
> Regarding the earlier discussion about sea_water, estuaries, rivers,
> runoff, etc., we have had previous conversations on the mailing list about
> a generic name for bodies of water on the earth’s surface, but have never
> reached agreement on a suitable term. I think flood_water is a useful way
> of describing temporary surface water – if in future there is a need to
> further distinguish between storm surges, tsunamis, and so on, then we can
> always introduce more specific standard names.
>
> The following is a summary of the current status of your proposals. I have
> taken into account the discussion in this thread and in some cases I have
> modified the definitions a little for consistency with existing names. In
> particular, I have added wording in the definitions of the names requiring
> thresholds to make them consistent with the recent discussions we had on
> GOES-R standard names. If you are happy with these suggestions then I think
> we can go ahead and accept all the names for publication in the standard
> name table.
>
> 1. flood_water_thickness (m)
> 'The flood_water_thickness is the vertical distance between the surface of
> the flood water and the surface of the solid ground, as measured at a given
> point in space. The standard name ground_level_altitude is used for a data
> variable giving the geometric height of the ground surface above the geoid.
> "Flood water" is water that covers land which is normally not covered by
> water.'
>
> 2. flood_water_speed (m s-1)
> 'Speed is the magnitude of velocity. Flood water is water that covers land
> which is normally not covered by water.'
>
> 3. eastward_flood_water_velocity (m s-1)
> 'A velocity is a vector quantity. "Eastward" indicates a vector component
> which is positive when directed eastward (negative westward). Flood water
> is water that covers land which is normally not covered by water.'
>
> 4. northward_flood_water_velocity (m s-1)
> 'A velocity is a vector quantity. "Northward" indicates a vector component
> which is positive when directed northward (negative southward). Flood water
> is water that covers land which is normally not covered by water.'
>
> 5. ground_level_altitude (m)
> 'The ground_level_altitude is the geometric height of the upper boundary
> of the solid Earth above the geoid, which is the reference geopotential
> surface. The geoid is similar to mean sea level.'
>
> 6. time_when_flood_water_rises_above_threshold (s)
> 'The quantity with standard name
> time_when_flood_water_rises_above_threshold is the time elapsed between the
> breaking of a levee (origin of flood water simulation) and the instant when
> the depth first rises above a given threshold at a given point in space. If
> a threshold is supplied, it should be specified by associating a coordinate
> variable or scalar coordinate variable with the data variable and giving
> the coordinate variable a standard name of flood_water_thickness. The
> values of the coordinate variable are the threshold values for the
> corresponding subarrays of the data variable. If no threshold is specified,
> its value is taken to be zero. Flood water is water that covers land which
> is normally not covered by water.'
>
> 7. time_of_maximum_flood_depth (s)
> 'The quantity with standard name time_of_maximum_flood_depth is the time
> elapsed between the breaking of a levee (origin of flood water simulation)
> and the instant when the flood depth reaches its maximum during the
> simulation for a given point in space. Flood water is water that covers
> land which is normally not covered by water.'
>
> 8. time_when_flood_water_falls_below_threshold (s)
> 'The quantity with standard name
> time_when_flood_water_falls_below_threshold is the time elapsed between the
> breaking of a levee (origin of flood water simulation) and the instant when
> the depth first falls below a given threshold, having already risen to its
> maximum depth, at a given point in space. If a threshold is supplied, it
> should be specified by associating a coordinate variable or scalar
> coordinate variable with the data variable and giving the coordinate
> variable a standard name of flood_water_thickness. The values of the
> coordinate variable are the threshold values for the corresponding
> subarrays of the data variable. If no threshold is specified, its value is
> taken to be zero. Flood water is water that covers land which is normally
> not covered by water.'
>
> 9. flood_water_duration_above_threshold (s)
> 'The quantity with standard name flood_water_duration_above_threshold is
> the time elapsed between the instant when the flood depth first rises above
> a given threshold until the time it falls below the same threshold for a
> given point in space. If a threshold is supplied, it should be specified by
> associating a coordinate variable or scalar coordinate variable with the
> data variable and giving the coordinate variable a standard name of
> flood_water_thickness. The values of the coordinate variable are the
> threshold values for the corresponding subarrays of the data variable. If
> no threshold is specified, its value is taken to be zero. Flood water is
> water that covers land which is normally not covered by water.'
>
> Best wishes,
> Alison
>
> ------
> Alison Pamment                                 Tel: +44 1235 778065
> Centre for Environmental Data Analysis         Email:
> alison.pamment at stfc.ac.uk
> STFC Rutherford Appleton Laboratory
> R25, 2.22
> Harwell Oxford, Didcot, OX11 0QX, U.K.
>
>
> From: CF-metadata [mailto:cf-metadata-bounces at cgd.ucar.edu] On Behalf Of
> Eizi TOYODA
> Sent: 16 September 2015 11:20
> To: CF Metadata List
> Subject: Re: [CF-metadata] new standard names for flood simulation
>
> Dear CF community,
> One month has passed silently after the discussion converged.  Is there
> anything to do for registration into the standard name table?
>
> Best Regards,
> Eizi
>
> P.S. for anyone interested, updated description and a sample CDL are
> available at:
>   desc - https://gist.github.com/etoyoda/efb7ceeb010e71d0105c
>   CDL - https://gist.github.com/etoyoda/1ad78c1df01126c3e731
>
>
>
>
> Best Regards,
> --
> Eiji (aka Eizi) TOYODA
> http://www.google.com/profiles/toyoda.eizi
>
> On Fri, Aug 14, 2015 at 5:37 PM, Eizi TOYODA <toyoda at gfd-dennou.org>
> wrote:
> Dear Jonathan,
>
> 1) I mean flood_water_thickness makes sense enough and I'm glad to use it.
>
> 9) Yes, I and colleagues are happy to use
> flood_water_duration_above_threshold.
>   When possible, it is good to have names sound natural for people
> speaking English everyday :)
>
> Thank you so much!
>
> Best Regards,
> Eizi
>
>
> Best Regards,
> --
> Eiji (aka Eizi) TOYODA
> http://www.google.com/profiles/toyoda.eizi
>
> On Fri, Aug 14, 2015 at 1:40 AM, Jonathan Gregory <
> j.m.gregory at reading.ac.uk> wrote:
> Dear Eizi
>
> > I'd use flood_water_thickness.
> If you're happy with that it and it makes sense to you and your colleagues,
> it would be the choice most consistent with other names.
>
> > Your second suggestion height_of_flood_water_surface_above_ground_level
> is
> > no problem at all, but a bit long for beginners of CF.
> I agree.
>
> > 9) time_duration_with_flood_water_above_threshold
> > I wonder perhaps "time_duration" could be "duration", looking at
> > duration_of_sunshine.
> "[time] duration with flood" etc. sounds a bit strange to me. I see that
> "flood water duration" is a phrase that occurs (in Google). Would you
> consider
> flood_water_duration_above_threshold?
>
> > Regarding 6), our planned data is only for the case of threshold=zero,
> but
> > it is no problem to generalize the concept to be symmetric with the
> > "falls_below" counterpart.
> OK. I suppose you will need a scalar coordinate variable with a
> standard_name
> of flood_water_thickness to supply the threshold, and this should have a
> default - perhaps zero would be a suitable default.
>
> I think your use of flags and strings to describe hazard conditions is
> good,
> and I appreciate that at this point you don't need to standardise them.
>
> Best wishes
>
> Jonathan
> _______________________________________________
> CF-metadata mailing list
> CF-metadata at cgd.ucar.edu
> http://mailman.cgd.ucar.edu/mailman/listinfo/cf-metadata
>
>
> _______________________________________________
> CF-metadata mailing list
> CF-metadata at cgd.ucar.edu
> http://mailman.cgd.ucar.edu/mailman/listinfo/cf-metadata
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.cgd.ucar.edu/pipermail/cf-metadata/attachments/20150918/b12b7d0a/attachment-0001.html>


More information about the CF-metadata mailing list