[CF-metadata] Feedback requested on proposed CF Simple Geometries

Jonathan Gregory j.m.gregory at reading.ac.uk
Wed Feb 1 10:00:40 MST 2017


Dear Chris

> I really don't like storing info like this in an attribute -- I think it
> should be another variable, instead. it is a bit tricky with "nested" data
> like this, but yu can link variables together with something like:
> 
>     int SOMETHING(station); // number of polygons in each collection
>       SOMETHING:node_coordinates="lon lat";
>       SOMETHING:geometry_type="multipolygon";
>       SOMETHING:node_count="node_count_1"
>     int node_count_1(num_nodes);
> 
> ...
> data
>     node_count_1 = 4, 3, 3, 3, 5, 3, 3;

Yes, I thought of doing it that way too: that is, use a string attribute to
name a vector integer variable, rather than using a vector integer attribute.
This/your way is more consistent with CF in general, where we have few vector
attributes, and none with variable dimension. So I actually prefer it. I didn't
do it that way because I thought it looked simpler with an attribute. But I
don't mind.

> Thus I
> > have combined the two variables I suggested last time (number_of_parts and
> > number_of_nodes) into SOMETHING.
> >
> I think we should come up with a better name here -- it would help be parse
> it anyway :-)

Indeed. :-) SOMETHING is just the variable name, not the term for this kind
of variable. It might be called a topology variable, for instance.

Speaking of that, I wonder whether topology_type is a better name than
geometry_type for the specification as points, lines or polygons. That is
topological information.

Best wishes

Jonathan



More information about the CF-metadata mailing list