[CF-metadata] Feedback requested on proposed CF Simple Geometries

David Blodgett dblodgett at usgs.gov
Wed Feb 1 11:07:23 MST 2017


Dear Jonathan and Chris, 

Thanks for bringing this thread back to life! Please don’t take silence on the part of Ben and I as a lack of activity. 

We have been working on a thorough proposal and are hoping to share it with the community very soon.

Chris, I think you will find a number of things in our proposal to your liking. We have attempted to reconcile a number of issues you brought up with our original proposal and the ideas the Jonathan shared. 

We are working through one last issue (what to do with the old “point” feature type now that we have geometries that are a superset). Once we have some finality on that, I will be circulating a proposal.

Regards.

- Dave
 
> On Feb 1, 2017, at 11:00 AM, Jonathan Gregory <j.m.gregory at reading.ac.uk> wrote:
> 
> Dear Chris
> 
>> I really don't like storing info like this in an attribute -- I think it
>> should be another variable, instead. it is a bit tricky with "nested" data
>> like this, but yu can link variables together with something like:
>> 
>>    int SOMETHING(station); // number of polygons in each collection
>>      SOMETHING:node_coordinates="lon lat";
>>      SOMETHING:geometry_type="multipolygon";
>>      SOMETHING:node_count="node_count_1"
>>    int node_count_1(num_nodes);
>> 
>> ...
>> data
>>    node_count_1 = 4, 3, 3, 3, 5, 3, 3;
> 
> Yes, I thought of doing it that way too: that is, use a string attribute to
> name a vector integer variable, rather than using a vector integer attribute.
> This/your way is more consistent with CF in general, where we have few vector
> attributes, and none with variable dimension. So I actually prefer it. I didn't
> do it that way because I thought it looked simpler with an attribute. But I
> don't mind.
> 
>> Thus I
>>> have combined the two variables I suggested last time (number_of_parts and
>>> number_of_nodes) into SOMETHING.
>>> 
>> I think we should come up with a better name here -- it would help be parse
>> it anyway :-)
> 
> Indeed. :-) SOMETHING is just the variable name, not the term for this kind
> of variable. It might be called a topology variable, for instance.
> 
> Speaking of that, I wonder whether topology_type is a better name than
> geometry_type for the specification as points, lines or polygons. That is
> topological information.
> 
> Best wishes
> 
> Jonathan
> _______________________________________________
> CF-metadata mailing list
> CF-metadata at cgd.ucar.edu
> http://mailman.cgd.ucar.edu/mailman/listinfo/cf-metadata
> 




More information about the CF-metadata mailing list