<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">My CDL-reading was off a bit yesterday, so:</div><div class="gmail_quote"><br></div><div class="gmail_quote">On Tue, Jan 31, 2017 at 1:22 AM, Jonathan Gregory <span dir="ltr"><<a href="mailto:j.m.gregory@reading.ac.uk" target="_blank">j.m.gregory@reading.ac.uk</a>></span> wrote:<br><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">So, for example, we could<br>
store three timeseries, each applying to a collection of polygons, like this:<br>
<br>
  dimensions:<br>
    station = 3; // collections of polygons<br>
    time = UNLIMITED;<br>
    node = 24; // = 4 + 3 + 3 + 3 + 5 + 3 + 3<br>
  variables:<br>
    float flow(station,time) ;<br>
      flow:units="m3 s-1";<br>
      flow:topology="SOMETHING";<br>
    double time(time) ;<br>
      time:standard_name = "time";<br>
      time:units = "days since 1970-01-01 00:00:00" ;<br>
    int SOMETHING(station); // number of polygons in each collection<br>
      SOMETHING:node_coordinates="<wbr>lon lat";<br>
      SOMETHING:geometry_type="<wbr>multipolygon";<br>
      SOMETHING:nodes=4, 3, 3, 3, 5, 3, 3; // number of nodes in each polygon<br></blockquote><div><br></div><div>I really don't like storing info like this in an attribute -- I think it should be another variable, instead. it is a bit tricky with "nested" data like this, but yu can link variables together with something like:</div><div><br></div><div>    int SOMETHING(station); // number of polygons in each collection<br>      SOMETHING:node_coordinates="<wbr>lon lat";<br>      SOMETHING:geometry_type="<wbr>multipolygon";</div><div>      SOMETHING:node_count="node_count_1"</div><div>    int node_count_1(num_nodes);</div><div><br></div><div>...</div><div>data</div><div>    node_count_1 = 4, 3, 3, 3, 5, 3, 3;</div><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Thus I<br>
have combined the two variables I suggested last time (number_of_parts and<br>
number_of_nodes) into SOMETHING.<br></blockquote><div><br></div><div>I think we should come up with a better name here -- it would help be parse it anyway :-)</div><div><br></div><div>-CHB</div><div><br></div></div><div><br></div>-- <br><div class="gmail_signature"><br>Christopher Barker, Ph.D.<br>Oceanographer<br><br>Emergency Response Division<br>NOAA/NOS/OR&R            (206) 526-6959   voice<br>7600 Sand Point Way NE   (206) 526-6329   fax<br>Seattle, WA  98115       (206) 526-6317   main reception<br><br><a href="mailto:Chris.Barker@noaa.gov" target="_blank">Chris.Barker@noaa.gov</a></div>
</div></div>